Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Deepin grub customizer. Now BIOS doesn't work. Seriously

Started by 3141592654, November 04, 2016, 02:08:25 AM

Previous topic - Next topic


Lenovo ideapad z560 0914, the Nvidia GeForce 310 edition
Windows 7 x64 with current updates installed
Kali rolling, latest updates.
Sparky game over, latest as of last night
I did use grub customizer to theme things out before, and it worked perfectly.
Somehow Deepin managed to beat up my BIOS

Installed Deepin. Played through the options. Tried Deepin's custom theme on grub. Tried to restart. Now my computer won't even go to POST. I get the power lights, the keyboard LEDs, the fan spins up, the optical briefly lights. But I get no Lenovo logo that always comes up. After all the above happens, all the lights go off, as if reset, and it repeats the whole process.

I have tried using the novo button, which gives same results.
Power draining, which is no battery, no wall wart, holding power button at many different intervals.
I've let it try for over an hour, just to be optimistic.
I've removed all the hardware that can be, RAM, HDD, optical, and the different parts like keyboard, touchpad, light board, graphics cable, and plugging things in one at a time.

This looks exactly as it did when my prior motherboard fried after a bad BIOS update.
There has not been a BIOS update ran here.

Unfortunately, Lenovo does not have this model, the 0914, BIOS downloadable as an update or anything else. I've looked all over for the exact version 2.19, insydeh2o, and I've not found the correct flash for it when the other motherboard for zonked.
Any help at all would be massively appreciated, please.


One possible solution is to boot a live-cd, chroot into your hdd installation and reinstall & update grub. I am presuming you are using a bios boot and not a gpt boot for these instructions.

First boot a live-cd (I have used many different ones and they all worked the same) then go to a terminal and beginn the following process...

Assumption 1: (other OS) is installed on /dev/sda1 but is not accessible via grub
Assumption 2: /dev/sda1 is the root partition, and you do not have a separate boot partition
Goal: reinstall grub in mbr of /dev/sda:

sudo mkdir -p $TARGET
sudo mount /dev/sda1 $TARGET
sudo mount --bind /dev     $TARGET/dev
sudo mount --bind /dev/pts $TARGET/dev/pts
sudo mount --bind /proc    $TARGET/proc
sudo mount --bind /sys     $TARGET/sys
sudo chroot $TARGET /bin/bash

This places you in a root terminal on the (other OS) system Do whatever you want to do there, e.g. re-install & update grub

grub-install /dev/sda

To exit from chroot:
press ctrl-D or enter exit
This brings you back to where you were in the live session and you can unmount

sudo umount -l $TARGET/dev/pts
sudo umount -l $TARGET/dev
sudo umount -l $TARGET/proc
sudo umount -l $TARGET/sys

Thats it...

Reboot into the (other OS) system on HDD.


Booting at all is not possible. I know how to change root and install grub. That's not the problem. Computer is not getting into POST, the bit that starts BIOS and displays the Lenovo logo before any booting can begin. What's not happening here is BIOS, which allows any booting to occur, be it USB, optical, or any HDD I could put in there or on the eSATA port It really looks as if somehow it wiped my EC or possibly BIOS itself... My guess is that Deepin thought is was updating GPT/UEFI, but I'm using an msdos partition table and it wrote to a terribly wrong address.
Sorry if my information was not conveyed. I'm prone to that. Thanks for trying. I honestly appreciate your time.


Sorry about that, I just re-read your first post and you did explain your problem fully, I must have skimmed it and not read it properly. I,m not sure how this could occur from a grub modification though, (but I'm no expert).
I just ran a quick google on it and came across this post which concludes a faulty motherboard, so maybe it's the bad news we never like to hear...


I haven't had problems with the motherboard here, but the looping without logo smacks of BIOS corruption, like the bad flash I did on the other board


I found what appears to be the latest bios for your machine at the Lenovo support site but I cannot see how you can flash it without loading windows first. It might be worth an email to them to see if they have other instructions.


Did you find a download for version 2.19? I've searched lenovo site by using their model number/serial number/regular search box and even used Google advanced search many times. it would be amazing if you have found the correct version.
Being that it's insydeh2o BIOS, it can be flashed in emergency mode, which is hold Meta+R or Meta+B and then plugging in the power, and while still holding the buttons, press power. The BIOS needs to have the 40ww, aka 2.19, to work for this board. The generic z560/z565/z460 are for 4 MB chips, with integrated Intel GPU. Mine is the 0914 model, which has 8 MB flash to support the dedicated nvidia GPU. I tried v2.17 with the prior board, and after it flashed, nothing worked including USB, and i could not enter emergency flash mode afterwards. The v2.17 does not correspond to exactly the same board, it's for compal LA-5752P rev0.3 instead of LA-5752P rev1.0. I have the schematics for the 0.3 revision. The main differences are BIOS flash size, and soldered in GPU and VRAM, but the BIOS for 2.17 will not work.


The text file of the link i provided shows 29CN38WW (V2.15) I don't use Lenovo myself so cannot say if this is the latest one for your machine or not, but if you are looking for 2.19 I would guess it's not.


v2.17 is latest for rev 0.3 board. Rev 1.0 is v2.19. Therefore, that isn't the file. Installing that BIOS will completely brick it. There has been no upgrade for 0914, GeForce board.


Would this repair tool be any help?

I just read through the post and it is probably not going to help as you cannot boot a system to use it... but I'll leave the post for information.

View the most recent posts on the forum