Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Sparky as VirtualBox guest

Started by xeddog, June 15, 2015, 06:40:46 PM

Previous topic - Next topic


I have a linux machine running Ubuntu 14.10 64-bit, onto which I have installed Virtualbox currently at 4.3.28.  I have Sparky 3.6 installed on two different guest vms.  One is Sparky 3.6 E19 64-bit, and the other is Sparky 3.6 Gameover 64-bit.  I have the same problem with both.

After installing Sparky, I open a terminal and run "sudo apt-get update", followed by "sudo apt-get upgrade".  The update fails because libcap-ng0 doesn't get installed so I "sudo apt-get install libcap-ng0" which completes normally.  I then run the "sudo apt-get upgrade again and this time it completes normally.  Then I run "sudo pat-get dist-upgrade which also completes normally.  I don't think any of this is related to my problem, but this is the setup.  Btw, it doesn't matter if I install the guest additions before running all of the updates updating either. 

Now the problem.  When I reboot the vm I get the black screen with a non-blinking cursor in the upper left corner.  I have read that this may be a video driver issue, and since I have not installed the VBox guest additions yet, maybe so.  The problem is, I cannot get the guest additions image to mount.  Even after

From the black screen, I can do a ctl-alt-f1 (actually a Right-ctl and f1 in a VirtualBox guest) and get a terminal login, but from there I cannot find the guest additions image.  I have seen some threads about how to get it mounted, but non of the solutions help me at all.  In my other linux machines, real and virtual, the image will be located at /media/<userid>/VBOX_image_name.  Prior to trying to insert the image, the /media directory is empty.  After inserting I have /media/<userid>, but nothing else.

Is there anything else I can try?


You don't have to mount the guest-additions.iso image, simply run your virtual installation in the recovery mode and install "virtualbox-guest-utils" package via the package manager:,3071.msg6106.html
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Wow, that was easy.  Even better, it worked!    ;D



View the most recent posts on the forum