Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

volid option of ISO file

Started by patrick, June 02, 2015, 01:57:18 AM

Previous topic - Next topic

patrick

I think the problem is I didn't comment out 64 bit option
and the ISO file was not created.     It looks like there is a
full /live and /isolinux directory's in /ISOTMP.

Can I manually make the ISO from there with genisoimage,
or is the whole process needed again ?     Filesystem.squash
is 912 MB.      I'm almost tempted to do a frugal install,
everything looks like it's there.

Advise ?

THX

edit: frugal setup boots but will not accept user/password at
graphic login screen.   

pavroo

#1
If you vave the squashfs made already, go to directory:
/ISOTEMP/ISOMOUNT
and create the iso manually:
xorriso -as mkisofs -rock -omit-version-number -disable-deep-relocation -joliet -allow-leading-dots -volid "your-volid-name" -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -eltorito-alt-boot -e boot/grub/efi.img -no-emul-boot -o "/patch-to-working-dir/new-image.iso" "/patch-to-working-dir/ISOTEMP/ISOMOUNT"
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

patrick

Hi,

I think the iso refuses to create because the working
directory is another hard drive.    So I make an iso out
of /ISOTEMP and it refuses to login.      Boots into the
lightdm screen.         What next ?       It's stuck there
with incorrect password.

thanks for the response,

Patrick

pavroo

#3
It happens when the live user's /home directory is to large.
Have you put extra files to /etc/skel dir or have you installed something what is installed in /home directory, such as steam or so?

The second possible reason is new version of live scripts. Have you upgraded packages of the chrooted system before making new iso?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum