Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Openjdk7-jdk : no way to install on Sparky Linux 4.3 ?

Started by NexusPenguin, May 02, 2016, 07:04:27 PM

Previous topic - Next topic

NexusPenguin

Hi,

Sparky Linux is based on Debian testing.

It seems that all openjdk-7 packages have been removed from the Debian packages sources.
So the only openjdk available for Sparky is the version "8".

Among other activities, I build Android custom ROMs.
But to build those, except if I want to build the not even released Android "N", I need Openjdk-7.

Unfortunately, it seems there is no way for me to install that one (those nasty dependencies are never fullfilled !).

So I had to install another distro to be able to use my Linux for what it's meant to do :-(
I must that I hardly regret this, as Sparky was really nice !

So if anyone knows how to install openjdk-7-jdk on Sparky 4.3, I'll take it's advice to put it into use again :-)

Thanks a lot...

Regards.

tux

You need cherry-pick it from Debian Stable or Experimental or you can download OpenJDK7 source code and compile it yourself.
https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=openjdk-7-jdk

seonine

beside the "normal" testing repo I added

deb http://ftp.debian.org/debian/ stable main contrib non-free

to my sources.list.d.... kind of frankendebian - but it works just fine!

no probs with lsb-core or other dependencies, because something is
moved away in testing....

JUST MY WAY

SeONine

NexusPenguin

Quote from: tux on May 03, 2016, 08:39:37 AM
You need cherry-pick it from Debian Stable or Experimental or you can download OpenJDK7 source code and compile it yourself.
https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=openjdk-7-jdk

Hi Tux,

Thanks for the link, but I don't think it's useful to me :-(

Two main reasons to that :
- there is no version available for Debian Stretch (as you may have noticed) ;
- there is no version for above "Jessie" available for amd64 (only arm) ;
- the version for Jessie will not install on strech because of missing dependencies... that are never fullfilled :-(

I guess it will be the same if I try to compile myself : there will always be a component not found...
But I will try that eventually...

Regards.

FRED

pavroo

The openjdk-7 is still in jessie repos:
https://packages.debian.org/search?keywords=openjdk-7
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum