Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Upgrade 2015-05-15

Started by pavroo, May 15, 2015, 11:51:54 PM

Previous topic - Next topic


I upgraded one of my virtual machine with Sparky today, got some updates of xserver-xorg-* packages and the machine did not get up after rebooting.
Anybody has the same problem on a normal machine?
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I did a full upgrade today (dev machine, not a VM) and no problems whatsoever.
There's no such thing as "impossible". :)


Just full upgraded - lxde 3.16 amd64 - ok until re-boot - opened to blank white screen - left mouse button brings up normal sparky log-in screen - ok from there.

Had to change those lines in lightdm.conf again-


autologin-user= myname

again and everything is back to normal for auto login.


 :'(  my razorqt i586 v3.6 virtual box installation after a dist-upgrade rebooted to a black screen with a with underscore, no prompt, no nothing, restored backup, tried again, same results.
Will try this afternoon with a standard upgrade.

Pavroo or others: Ideas please? cant get past that screen

Edit: I do not use autologin, just standard login screen, my installation is mostly (minus some wallpapers) "out of the box"


Looks like there are changes in video drivers.
I have recovered my vbox machine from older stage, did full upgrade and installed 'virtualbox-guest-utils' which lets me reboot and log in again normally.
But it still drives me crazy.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


QuoteIdeas please? cant get past that screen

For a normal installation try booting with a grub rescue disk ( and then try something like grub-customizer from the package list ...if it is a grub problem.


Run your vbox sparky installation in recovery mode.
Turn the internet connection on:
apt-get update
apt-get install virtualbox-guest-utils

Then reboot.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


 :o OK, did this:

-Run vbox sparky installation in recovery mode.
-At prompt gave root pass for maintenance
-Turned the Internet connection on, start Ethernet simply by running:
    dhclient eth0

-Then did:

  apt-get update
  apt-get install virtualbox-guest-utils

-Then rebooted OK to graphic login
-Logged in
-Installed latest virtualbox addins
  (4.27, am using 4.12 vbox with testing additions)

***Seems everything is working OK.



I went through the APT history log file (/var/log/apt/history.log, list limited to interesting/related packages only):

New packages

Upgraded packages
virtualbox:amd64 (4.3.26-dfsg-3, 4.3.26-dfsg-3+b2)
virtualbox-qt:amd64 (4.3.26-dfsg-3, 4.3.26-dfsg-3+b2)
x11-common:amd64 (7.7+8, 7.7+9)
xorg:amd64 (7.7+8, 7.7+9)
xserver-common:amd64 (1.16.4-1, 1.17.1-2)
xserver-xorg:amd64 (7.7+8, 7.7+9)
xserver-xorg-core:amd64 (1.16.4-1, 1.17.1-2)
xserver-xorg-dev:amd64 (1.16.4-1, 1.17.1-2)
xserver-xorg-input-all:amd64 (7.7+8, 7.7+9)
xserver-xorg-video-all:amd64 (7.7+8, 7.7+9)
xserver-xorg-video-ati:amd64 (7.5.0-1, 7.5.0-1+b1)
xserver-xorg-video-cirrus:amd64 (1.5.2-2+b1, 1.5.3-1)
xserver-xorg-video-fbdev:amd64 (0.4.4-1+b2, 0.4.4-1+b3)
xserver-xorg-video-intel:amd64 (2.21.15-2+b2, 2.99.917-1)
xserver-xorg-video-mach64:amd64 (6.9.4-2, 6.9.5-1)
xserver-xorg-video-mga:amd64 (1.6.3-2+b1, 1.6.4-1+b1)
xserver-xorg-video-neomagic:amd64 (1.2.8-1+b2, 1.2.9-1)
xserver-xorg-video-nouveau:amd64 (1.0.11-1, 1.0.11-1+b1)
xserver-xorg-video-openchrome:amd64 (0.3.3-1+b2, 0.3.3-1+b3)
xserver-xorg-video-r128:amd64 (6.9.2-1+b2, 6.10.0-1)
xserver-xorg-video-radeon:amd64 (7.5.0-1, 7.5.0-1+b1)
xserver-xorg-video-savage:amd64 (2.3.7-2+b2, 2.3.8-1)
xserver-xorg-video-sisusb:amd64 (0.9.6-2+b2, 0.9.6-2+b3)
xserver-xorg-video-tdfx:amd64 (1.4.5-1+b2, 1.4.6-1+b1)
xserver-xorg-video-trident:amd64 (1.3.6-2+b2, 1.3.7-1+b1)
xserver-xorg-video-vesa:amd64 (2.3.3-1+b3, 2.3.3-1+b4)
xserver-xorg-video-vmware:amd64 (13.0.2-3.1, 13.1.0-2)

Removed packages
xserver-xorg-video-siliconmotion:amd64 (1.7.7-2+b2)
xserver-xorg-video-modesetting:amd64 (0.9.0-1+b1)

I have two theories here:

  • (less probable) The removed modesetting package caused Xorg not to detect the video hardware in VirtualBox and installing guest additions fixed it.
  • (more probable) The virtualbox package update caused incompatibility with the Xorg-supplied drivers for VB-emulated hardware... and installing guest additions fixed it.

I would probably go with the second one here. The solution is... to install the guest additions and make sure that the drivers are 100% compatible with the VM (the Xorg bundled drivers might or might not be compatible with different VB versions; they're not developed by the VB devs, but by Xorg devs). ;) Maybe we should check if we're in an VirtualBox environment and install guest additions in Sparky's installer. It's not a trivial issue, but I'll add that to my "research" list.

As for the LightDM problems: there were some config file changes (the option to display or not the list of available users has been commented out), so maybe that's the problem here. I discarded the new config file and retained the old one and didn't have any problems with LightDM whatsoever.
There's no such thing as "impossible". :)



I'm trying to install Guest additions on top of sparkylinux-4.0-x86_64-cli.iso, using Virtualbox 5.

I'm performing the instructions as above posted by ELquia.

The module vboxfs, which is my primary reason for wanting guest additions, is not present.

I know this is an old thread, so I apologize in advance.


Download and install sparky 4.1 cli, the virtualbox-guest-utils is preinstalled there.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I've downloaded and installed 4.1-cli and the virtualbox-guest-utils were not there.  I installed them, but I still don't appear to have vboxsf.

root@sparky41:~# uname -a
Linux sparky41 4.1.0-2-amd64 #1 SMP Debian 4.1.6-1 (2015-08-23) x86_64 GNU/Linux


I have double checked it and it's true.
There is not virtualbox-guest-utils pre-installed in the cli edition.
But there is not virtualbox-guest-additions in Debian testing reos too.
There is virtualbox-guest-additions-iso only.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

View the most recent posts on the forum