Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[ Solved ] Laptop brightness keys

Started by way12go, April 07, 2015, 07:04:28 AM

Previous topic - Next topic

way12go

I've installed sparkylinux 4 RC on both desktop and laptop and the icons are awesome.

Previously I used  Mate and I could access laptop brightness keys etc also I was getting visual effects for the keys and now in LXDE the keys are no longer working. What is the app for it?
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

pavroo

#1
Install 'xbacklight' package.
Edit the file:
~HOME/.config/openbox/lxde-rc.xml
Before :
</keyboard>
paste the text:
<keybind key="XF86MonBrightnessDown">
      <action name="Execute">
        <command>xbacklight -20</command>
        <startupnotify>
          <enabled>yes</enabled>
          <name>Decrease screen brightness</name>
        </startupnotify>
      </action>
    </keybind>
  <keybind key="XF86MonBrightnessUp">
      <action name="Execute">
        <command>xbacklight +20</command>
        <startupnotify>
          <enabled>yes</enabled>
          <name>Increase screen brightness</name>
        </startupnotify>
      </action>
    </keybind>

Then re-login and use function keys or special + Up/Down keys to change brightness.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

way12go

Thanks, it's working. But, in previous Mate installations I could see the on-screen display of key effects now I can use the keys but there is no on-screen display.

Anyway it's okay.

Thanks again.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

cynclida

#3
On my laptop I got OSD working (for brightness and volume) applying the following steps:

general:
- installed xfce4-notifyd, stopped autostart of notification deamon unchecking it in Dsktop Session Settings
brightness:
- installed xfce4-power-manager, added it to autostart checking it in Desktop Session Settings
volume:
- installed volumeicon-alsa and created volumeicon.desktop in ~/.config/autostart/:

[Desktop Entry]
Name=Volumeicon
Exec=volumeicon
Terminal=false
Type=Application
Categories=Applications;GTK;
NoDisplay=true


After reboot, I had to check control for brightness keys in Power Management and for volume keys in Volumeicon. Now OSD works  :)

Adwaith R Krishna

#4
Tried all the stuff mention above..still not working, running sparky on lenovo z51-70

paxmark1

#5
http://sparkylinux.org/forum/index.php/topic,2305.0.html

QuoteSearch Before Posting

Search the Sparkylinux forums and Google for questions before posting.

New Questions Deserve New Threads

Do not add new questions to existing threads, start your own instead! This will make it easier for other members to provide support. This includes hijacking, do not ask unrelated questions in a user's existing support thread.

Do not resurrect support threads older than 6 months, outdated information can cause issues with newer releases.

Please look up the term necroposting

https://bbs.archlinux.org/viewtopic.php?id=101991

https://www.urbandictionary.com/define.php?term=Necroposting

New Post please.  Please give more details on your system ("inxi" is nice) and especially what version of Sparky and what DE (Desktop Environment)   are you using.  Reference  as having tried this post   

Also post what other places you have searched

What is also helpful is searching for the similar answers in other places.  Your search of the problem here on this forum was probably correct.  We are a small fish in the Debian and Linux environment.

peace out.



Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum