Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[Solved] Problem audio

Started by Calatea, March 09, 2015, 08:27:34 PM

Previous topic - Next topic

Calatea

Hi,
It's one months that Sparky's audio is off! I don't know why! I've  2 SO on this pc, and in Lubuntu I can ear all Music, Video ecc but here no.
Can someone  help me?
Thanks

pavroo

Run Gnome Alsa Mixer and check is something marked as mute.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

Nothing is marked as mute.
How do you  insert immage?  I've got 2 screenshot

pavroo

I have created quick howto:
http://sparkylinux.org/forum/index.php/topic,2921.0.html
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

#4
 http://postimg.org/image/520gf8ltf/
http://postimg.org/image/aepatd9pv/

pavroo

Show me the output:
lspci | grep Audio
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

#6
 serena@debian:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC282 Analog [ALC282 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Calatea

 serena@debian:~$ lspci | grep Audio
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 02)

pavroo

Looks like you have two cards.
Run: alsamixer and change the default card via F6 key.
Make sound test:
aplay /usr/share/sounds/alsa/*.wav
speaker-test -c 2

If still no effects show me:
lsmod | grep snd
cat /proc/asound/cards
grep 'audio' /etc/group
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

serena@debian:~$ lsmod | grep snd
snd_hda_codec_realtek    67127  1
snd_hda_codec_hdmi     45118  1
snd_hda_codec_generic    63107  1 snd_hda_codec_realtek
snd_hda_intel          26327  8
snd_hda_controller     26727  1 snd_hda_intel
snd_hda_codec         104463  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13148  1 snd_hda_codec
snd_pcm                88662  5 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              26614  1 snd_pcm
snd                    65244  23 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              13026  2 snd,snd_hda_codec
serena@debian:~$ cat /proc/asound/cards
0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0x90240000 irq 76
1 [Generic_1      ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0x90244000 irq 77


How you can imagine the sound test failed. So that is the next.

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea


pavroo

I asked you before to show me the output too:
grep 'audio' /etc/group
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

serena@debian:~$ grep 'audio' /etc/group
audio:x:29:pulse,serena

pavroo

OK, it looks fine.
The Kabini HDMI card modules are loaded, but doesn't work, but I found nothing in the net to fix it.
FCH Azalia doesn't work at all but some guys fixed it after removing pulseaudio.
So uninstall 'pulseaudio' package, reboot and run alsamixer after (F2 and F6) to choose the second card.
Let me know does it help.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum