Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[Solved]Boot

Started by Calatea, December 26, 2014, 10:33:53 PM

Previous topic - Next topic

Calatea

Hi, I've installated Sparky LXDE on /dev/sda4, on /dev/sda 2 I've Lubuntu, but I can't choose at boot because this message appears: "debian has been blocked by the current security policy" [ok] you can only click on ok and Lubuntu boot. I'm not sure about grub and I write  sudo apt-get install grub after this the situation it's same at new boot the same message appears and then Lubuntu boot.
What I must doing? Where is the error?
Thanks for your help.

pavroo

Do you have Win8 and EFI?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

No, I've Lubuntu on /dev/sda2 and Sparky on /dev/sda4. File system FAT 32 mounted /boot/EFI

pavroo

But it looks like your machine has EFI - /boot/EFI is there.
So the question is does Lubuntu use EFI too?
Check has Lubuntu installed grub-pc or grub-efi?
What else you have in /boot/EFI? Only debian.efi image?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

#4
1)  I think that Lubuntu use EFI
2) I don't know
3) I think so, because Lubuntu is the first SO installated on this PC (Acer Aspire E1-522)
in /boot I've: 2 folders /boot/efi and /boot/grub
in /boot/efi/EFI 2 folders /boot/efi/EFI/debian and /boot/efi/EFI/ubuntu
in /boot/grub 3 folders: /boot/grub/fonts, /boot/grub/locale, /boot/grub/x86_64-efi +  files: grub.cfg, grubenv, unicode.pf2

pavroo

#5
I don't have big experience with efi, my machines have bios. I only work with efi on virtual machines.
But mayby it's a question of secure boot?
Can you check in efi settings is the secure boot turned off?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

I've open the BIOS menu, I've changed in security menu Secure boot to UEFI at Legacy, press F10 and I've receive this message:


Intel UNDI, PXE 2.0 (build 083)
Copyrigth IC 1997-2000 Intel Corporation v 2.1.1.4 (01/18/13)
Check cable connetion!
PXE-M0F: Exiting Intel PXE ROM
No bootable device -- insert boot disk and press any key.

Thus I've rebboted and changed in default (UEFI)

pavroo

I didn't say to turn it to Legacy.
The point is to turn the Secure Boot off.
http://acer--uk.custhelp.com/app/answers/detail/a_id/27071/~/how-to-enable-or-disable-secure-boot
It should be booted using efi image without secure boot.
By the way, if you don't have win8 why do you use efi if you can permanently turn it off and use legacy boot for all your OSes?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Calatea

Ok,  tanks exact information :D :D now at boot I've Grub but,  when  load the  system and I've the Grub on screen I don't see the Lubuntu partition. I've read that Lubuntu is default, it's means that if I wait whitout make any choose Lubuntu boot automaticaly?

Calatea

Good evening guys,
now that the Grub in installated I've another problem at boot grub don't see the partition /dev/sda2 where's Lubuntu.
What can I had to do for have, inside at the grub two option for choose: Lubuntu or Sparky?

Calatea

Solved!!! Was very easy:

#update grub

and now at boot I can see /dev/sda2 and /dev/sda4 at boot!!

Tanks and Happy New Year!

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum