Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Suggestions for MATE-packages

Started by py-thon, December 14, 2014, 05:10:41 PM

Previous topic - Next topic

py-thon

I noted that current Sparky Mate still uses mate-core in version 1.8.0+jessie. It seems to me that the current version is 1.8.0+7 (that's the one in testing), which apt (probably for alphanumeric reasons) considers older than 1.8.0+jessie, so the package won't be updated.
Another aspect: package mate-desktop-environment is not installed. My system (started as 3.5) ran well without it but apt-get autoremove wants to purge pluma and pluma-common without m-d-e so it would be safer to include m-d-e.

Edit: This should have gone into "Suggestions". Maybe you can move it there.
Tower and Notebook: Sparky 64bit MATE

pavroo

QuoteSparky Mate still uses mate-core in version 1.8.0+jessie. It seems to me that the current version is 1.8.0+7 (that's the one in testing), which apt (probably for alphanumeric reasons)
It looks like that. mate-core 1.8.1 should resolve the problem (hope so).
Quotepackage mate-desktop-environment is not installed
I don't like it. I prefer core meta-package and add what I need.
mate-desktop-environment pulls to many packages for me.
Quoteautoremove wants to purge pluma
I never seen something like that yet, but I will keep my eye on it, thanks.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

py-thon

Quote from: pavroo on December 14, 2014, 10:29:06 PM
mate-core 1.8.1 should resolve the problem (hope so).
Or 1.10, which I suppose will come early next year, judging by the http://wiki.mate-desktop.org/roadmap which is almost done for 1.10.
I made a force install of 1.8.0+7. As 1.8.0+jessie is in no repository there is no risk of reversion to 1.8.0+jessie.

Quote from: pavroo on December 14, 2014, 10:29:06 PM
mate-desktop-environment pulls to many packages for me.
Ok, I can understand that. But I installed mate-desktop-environment, mate-desktop-environment-core and mate-desktop-environment-extras (all 1.8.0+7, a total of ~90 kB) yesterday and they didn't pull any additional packages.

Tower and Notebook: Sparky 64bit MATE

pavroo

Quotethey didn't pull any additional packages
Looks like all the additional packages are preinstalled manually already :)
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

MoroS

Quote from: py-thon on December 14, 2014, 05:10:41 PM
...apt-get autoremove wants to purge pluma and pluma-common...

That's because pluma was installed as a dependency for another package, which has already been removed. If you want to fix it do a reinstall of the pluma package. Manually installed packages are not checked as unneeded dependencies.
There's no such thing as "impossible". :)

py-thon

Quote from: MoroS on December 18, 2014, 11:15:22 AMThat's because pluma was installed as a dependency for another package, which has already been removed.
I know, that's why I suggested that Sparky MATE be released with the package mate-desktop-environment instead of without :)
Tower and Notebook: Sparky 64bit MATE

View the most recent posts on the forum