Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Switch from lxde to xfce

Started by hallenberger, November 09, 2014, 06:44:00 PM

Previous topic - Next topic

hallenberger

Hello!

I have problems with the lxde-edition of sparky-linux:
1.  lxsession update fails,
2. In sparky-APTus: clicking "fully update system" gives a terminal-window with title: "no shell found" ("Kann keine shell finden" in german).

So I will try xfce. So how can I change from lxde to xfce?

Thank you!

regards
thomas

pavroo

Hi
The problem with lxsession, which has to bee upgraded can be solved in easy way, check here:
http://sparkylinux.org/forum/index.php?topic=2701.msg4336#msg4336
If you still have a problem, let me know, I will write a more exact guide.

The second problem with "shell not found" - looks like you have installed the latest 'sparky-aptus-upgrade' package or another terminal emulator.
I posted how to fix that, on the end of the text:
http://sparkylinux.org/sparky-aptus-upgrade-0-1-7/
Simply run, as root:
update-alternatives --config x-terminal-emulator
to choose different terminal emulator.
In your case it should be: lxterminal.

To change from lxde to xfce, open Synaptic, refresh package list and install xfce4.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

hallenberger

Hello!

Thank you verry much for your answer. I will check it tomorrow.

And thank you for your work: sparky linux rocks!

regards

thomas

hallenberger

Hi!

Quote from: pavroo on November 09, 2014, 07:38:22 PM
Hi
The problem with lxsession, which has to bee upgraded can be solved in easy way, check here:
http://sparkylinux.org/forum/index.php?topic=2701.msg4336#msg4336
If you still have a problem, let me know, I will write a more exact guide.

This solves the problem, but after login I get this error-message:
"GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject"



Quote from: pavroo on November 09, 2014, 07:38:22 PM

The second problem with "shell not found" - looks like you have installed the latest 'sparky-aptus-upgrade' package or another terminal emulator.
I posted how to fix that, on the end of the text:
http://sparkylinux.org/sparky-aptus-upgrade-0-1-7/
Simply run, as root:
update-alternatives --config x-terminal-emulator
to choose different terminal emulator.
In your case it should be: lxterminal.

This solves the problem.

Thanks

regards
thomas

pavroo

QuoteThis solves the problem, but after login I get this error-message:
"GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject"
Remove the file:
~HOME/.config/autostart/lxpolkit.desktop
then reboot.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

hallenberger

Hi!

Thank you. Now it works perfect!

Regards

thomas

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum