Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Error Upgrading - bug?

Started by way12go, December 09, 2014, 01:21:55 PM

Previous topic - Next topic


No files to download.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up grub-pc (2.02~beta2-17) ...
dpkg: error processing package grub-pc (--configure):
subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

real 0m3.573s
user 0m2.008s
sys 0m0.404s

I tried to solve this using google but couldn't understand how this problem was solved for few others, I couldn't do what they did to solve this problem as their problem appeared to be slightly different and 1 or 2 other things didn't work. All apps/commands in sparky-aptus didn't solve it. So I will download new 3.6 and overwrite this.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.


 :) I installed Sparkylinux 32-bit without PAE on both of my PCs. Tower and Laptop.
Tower might need JWM. I can always get it from the repositories.
Laptop doesn't need JWM.
Thanks Pavroo, Moros and all Sparkylinux contributers.

Great work.

If I ever get a chance I'll donate without failure.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.


Errors were encountered while processing:

In a case if somebody gets the same.
It looks like you did not choose an action during upgrading grub-pc from beta2-15 to beta2-17.
The installer ask to choose between keeping current version of grub config and a new one.
Just I guess.
'dpkg --configure -a' should fix it.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

View the most recent posts on the forum