Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[ Solved ] Lightdm-manager doesn't auto login

Started by way12go, September 23, 2014, 07:16:49 AM

Previous topic - Next topic

way12go

Lightdm-manager doesn't auto login

I searched the internet and found this solution. I haven't tried this solution as I need to go to bank. If this works I will not change the status of this post's subject.

Here it is...

Quotehttp://siripong-computer-tips.blogspot.in/2011/09/enable-lightdm-autologin-debian-wheezy.html

Quoteenable lightdm autologin debian wheezy

alter /etc/lightdm/lightdm.conf to be

[SeatDefaults]
autologin-user={YOUR USER NAME}
autologin-user-timeout=0
pam-service=lightdm-autologin


create /etc/pam.d/lightdm-autologin (if not exist)
#%PAM-1.0
auth requisite pam_nologin.so
auth required pam_env.so readenv=1
auth required pam_env.so readenv=1 envfile=/etc/default/locale
auth required pam_succeed_if.so user != root quiet_success
auth required pam_permit.so
@include common-account
session required pam_limits.so
@include common-session
@include common-password


thanks
=======
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

way12go

Auto login used to work after I changed a file related to auto login as in this post...

Quotehttp://sparkylinux.org/forum/index.php?topic=2581.msg3791#msg3791

After I installed lidhtdm-manager auto login no longer works and the first post in this topic seems to be the solution...
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

way12go

The above solution doesn't work. Light-dm manager auto login is enabled but it simply doesn't work.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

way12go

I have KDE, GNOME, LIGHT-DM and SLIM installed. Is this the cause why I couldn't autologin?
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

pavroo

QuoteAfter I installed lidhtdm-manager auto login no longer works and the first post in this topic seems to be the solution
It looks like the Lightdm-manager doesn't solve the problem.
Mayby it's better to not install the manager and configure the lightdm configuration file manually.

Somebody asked me to add the manager to the iso but I am not sure that it's a good idea.
I just added the package to our repository.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

way12go

I uninstalled "slim and slim-theme" and then I uninstalled "lightdm" and then I installed "lightdm" and now it works like a charm. All I have to do is uninstall it and install it... I suppose when there are login managers like kdm, gdm3, slim and lightdm, the last installed login manager that is installed should be lightdm and slim should be uninstalled.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

View the most recent posts on the forum