Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[Solved] Linux USB Mouse auto suspend. The mouse power is going off.

Started by way12go, July 22, 2014, 10:25:35 AM

Previous topic - Next topic

way12go

Well I installed Sparkylinux LxDE and updated it, everything went well except few glitches happen here and there such as mouse freezing and for once the sparky center didn't work and once shutdown didn't occur.

The main problem is mouse is freezing. My previous linux distro is linux mint and I had a 500 Rupees Logitech mouse it would work and it freezed and this happened time to time... what do I mean by freezing? The mouse pointer didn't freeze... the touch pad was always working. I had to remove the usb mouse and reinsert it to get it to work. I opened the mouse and it broke. I bought a new 250 rupee mouse and same thing is happening in Sparkylinux. Is this linux problem? I set BIOS to optimum - default settings. The mouse power is going off.

Hope I get a working solution.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

way12go

#1
http://superuser.com/questions/408683/why-my-usb-mouse-gets-suspended-after-3-seconds-of-inactivity
   

I have the perfect solution!

If

Quotefor i in /sys/bus/usb/devices/*/power/control; do echo on > $i; done

works for you, but only once,
Quotesudo gedit /etc/laptop-mode/conf.d/usb-autosuspend.conf
to replace :

QuoteCONTROL_USB_AUTOSUSPEND="auto"

by

QuoteCONTROL_USB_AUTOSUSPEND=0

It works for me.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

way12go


Quotesudo gedit /etc/laptop-mode/laptop-mode.conf
This  is  the  main  configuration  file.  It contains the settings for
       enabling and disabling, plus the core features: the Linux kernel laptop
       mode feature and related settings.

       ENABLE_LAPTOP_MODE_TOOLS
                 This  module determines if laptop-mode-tools should be run or
                 not. Default is 1 Set it to 0 if you would like to completely
                 disable laptop-mode-tools
Quote
Set

ENABLE_LAPTOP_MODE_TOOLS=0
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

way12go

The above solutions didn't work for me.

QuoteI simply went to Synaptic package manager and
Quoteuninstalled
Quote"laptop-mode-tools
"

QuoteProblem solved
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

MoroS

Quote from: way12go on July 23, 2014, 02:15:21 PM
QuoteCONTROL_USB_AUTOSUSPEND=0
Be careful with that one. It's a battery-sucker. Disabling USB autosuspend increases battery drain, as all USB-plugged devices (the ones outside aswell as the ones on the inside of a laptop: webcams, keyboard, touchpad, etc. - they're all usually connected via the USB interface) remain active even when unused.
There's no such thing as "impossible". :)

way12go

I simply uninstalled laptop mode tools and problem solved. Thanks for your suggestions.
Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

View the most recent posts on the forum