Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED] Wi-Fi Issue: Similiar Problem As Bluebriz

Started by perknh, August 17, 2014, 05:29:52 PM

Previous topic - Next topic


Hello SparkyLinux Forum,

I'm having a fun time here with SparkyLinux.  I'm finding Sparky's LXDE very fast and responsive.

The one problem I have is that I have no Wi-Fi connectivity.

I get the message in the panel wlan0  Connection has limited or no connectivity    When I left click I sometimes get a message that says Wireless Networks not found in range.  Then other times my secured Wi-Fi network is shown with about 90% strength.  Anyway, my computer, a Toshiba Satellite C-70, is right next to my TP-LINK 150 Mbps Wiireless N ADSL2 + Modem Router Model No.: TD-8951 ND, and I figure it should be working.

When I put in my modem router's password, nothing happens.  Also clicking on Repair does nothing either.

My SparkyLinux LXDE is updated, upgraded, and dist-upgraded, and I don't know what else to do.   :-\

Here are the results from my terminal after running pavroo's Code  lspci | grep Network:

*****@bluecat:~$ lspci | grep Network
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)

Thank you,



It's for Ubuntu, but should works for Debian too, check here:
and download package:
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thank you, pavroo.

I tried innumerable times with two alternate drivers.  You had an excellent idea there, but my exact driver was not to be found.

I even went as far as blacklisting the driver, and then trying a re-install through the terminal, but I had no luck.  You may know, or know of, Kendall Weaver, CTO of Peppermint OS.  (Peppermint OS is an excellent LXDE OS with a very supportive forum too.)  Well Kendall said to me, some time ago, that there were problems with Toshiba and Linux, but he told me that things were improving with Toshiba over time.

That being said, pavroo, I believe I hit a Toshiba roadblock here!

Thank you, pavroo, for your time and research here.  I actually learned quite a bit going through the steps of that post.

Thank you,



Hi. Could you post the output of the "dmesg" command after trying to connect? It may be a firmware problem.
There's no such thing as "impossible". :)


Yes, thank you MoroS, The output from dmesg exceeded 20000 characters so I've decided to delete that incomplete and enormous post that did not seem to help you very much.

MoroS, thank you.



Yep, it's truncated...  :-\ Maybe you could use some online pasting service like
There's no such thing as "impossible". :)


Thank you, MoroS.

I've read that there is a way use the dmesg command with an add-on command that could help specify information -- maybe for the firmware of which you are interested in seeing.  Do you know what I could add onto the dmesg command that would specify more clearly the information on firmware of which you are interested?

Here's what I mean: 

I'm sure you don't need, or want, all that info I had given you earlier.  With a little help here I might be able to be more specific while using the dmesg command.  I just don't know how to construct the command in a way that will be helpful to you.

Thank you.


Quote from: perknh on August 18, 2014, 06:02:17 PM
Do you know what I could add onto the dmesg command that would specify more clearly the information on firmware of which you are interested?
Just drop the whole output. Just make sure it doesn't contain anything you don't want to publish (it shouldn't). I don't know what am I looking for exactly yet. Anything that's uncommon. You could also add the /var/log/messages file (just make sure both are after you try to connect at least once). If something's not working it's those two files that I check first for anything suspicious. :) In the meantime I'll look for information about your wifi chipset. It's a RealTek chip, so it's quite common.
There's no such thing as "impossible". :)


Forgive me, MoroS, but since I don't know what a lot of this these things are that you are talking about, and since we're limited here to 20,000 characters.  I took the risk of sending two personal messages that only contain the output of the dmesg command --  and nothing more.

You now have the entire thing -- minus my wife's name!   ;)

By doing it this way, I thought, we won't clutter up this thread with that enormous output.  Please feel free to delete it all when you're finished looking at the output.  If you save what I sent you, you'll never have space in your inbox for anything else!

I would have edited the output for you, but I don't know what I'm editing.

MoroS, you know we've already done the most important thing we can do here: we have reported the issue.  In the long run this will help the developers working on Debian and Linux -- and that is what really counts.  You should know that I'm running fine right now with my Ethernet connection, so this is not an emergency of any kind.

Thank you very much,



I did some searching. Did you try to install the firmware package for Realtek cards? It's the firmware-realtek package. If you haven't already, then try it. That should work with the standard (as in non-alternative, as I don't know which one are you currently using) driver. A simple:
apt-get install firmware-realtek
and a reboot should be enough.
There's no such thing as "impossible". :)


Thank you, MoroS,

Here' what I got after running that command:

*****@bluecat:~$ sudo apt-get install firmware-realtek
[sudo] password for *****:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
firmware-realtek is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


MoroS, the previous post, where I ran the command sudo apt-get install firmware-realtek was written from my internal hard drive, where Sparky LXDE is installed. And as you can see, I was already up to date, so nothing changed concerning my wireless connectivity in Sparky.

But right now, I'm writing you from an external hard drive attached to my computer, using Peppermint OS.  And I'm writing you without being connected to an Ethernet cable at all.  I'm writing to you using my Wi-Fi connection in Peppermint!

Now a significant difference between Peppermint and Sparky is that Peppermint OS is based more directly on Lubuntu and less so on Debian.  (Although we all acknowledge that Debian is the father of Ubuntu.)

Here's my thought. I could run some tests for you here in Peppermint and then you could discover what is missing in Sparky's Debian OS.  Is this a good idea?

I just don't know what to run for you, but if this idea could help both you and pavroo make Sparky better, while helping out Debian in the mean time; I'd be glad to do whatever I can if it would help you from here if you wish.

You see I have the advantage of having two LXDE distributions right at my fingertips.  And the guys here at Peppermint OS are as friendly a group of guys as you can find.  They always urge me to venture out and learn more about Linux.  They'd be happy we're working together, I assure you.

I just don't know what to do next in order to help.



Can you try to load the module manually (as root):
modprobe -r rtl8188ee
modprobe rtl8188ee

Then check your wifi status.
Anyway 'dmesg' and 'lsmod' will be helpful if you can past it somewhere on external server such as pastebin.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thank you, pavroo.  I hope I'm doing things right.

I put the first command in the terminal with sudo and pressed Enter.  Then I did the same with the second command and pressed Enter again.  Now I lost the terminal the first time so I had to add my password two times.  The result of all of this is that my Wi-Fi is not showing its icon in the panel bar any longer.  Maybe that's what you were looking for, I don't know.  Anyway the Wi-Fi icon has disappeared.

Here's the command for Ismod.  The output isn't very large, and I will delete it after you look at it so as to not have such an ugly thread.


dmesg output 1of 5 -- to be deleted after being read.

The output has been deleted now that it is no longer needed.

View the most recent posts on the forum