Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[SOLVED] Wi-Fi Issue: Similiar Problem As Bluebriz

Started by perknh, August 17, 2014, 05:29:52 PM

Previous topic - Next topic

MoroS

Figures... :/

Next attempt. Again in the terminal:
sudo killall -9 nm-applet
gnome-keyring-daemon &
nm-applet

The first one will make sure we're starting clean. The next one launches the keyring daemon (no sudo needed). Give it a few seconds (if no errors are shown) and proceed to run the nm-applet yet again (again: no sudo needed).
There's no such thing as "impossible". :)

perknh

1) Did it.  Nothing much to show for it.

2) *****@bluecat:~$ gnome-keyring-daemon &
[1] 1829
leslie@bluecat:~$ gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-GnO32d
SSH_AUTH_SOCK=/run/user/1000/keyring-GnO32d/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-GnO32d/gpg:0:1
GNOME_KEYRING_PID=1830

3)*****@bluecat:~$ nm-applet

** (nm-applet:1920): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nm-applet:1920): Gtk-WARNING **: Theme directory scalable/stock of theme NoirCrystal has no size field



MoroS

Quote from: perknh on August 21, 2014, 02:44:28 PM
(nm-applet:1920): Gtk-WARNING **: Theme directory scalable/stock of theme NoirCrystal has no size field

Just a hunch really, but could you change the theme to something else than NoirCrystal (like Clearlooks) and fire up the nm-applet again?
There's no such thing as "impossible". :)

perknh

#63
Okay, I changed my Widget to Clearlooks and I change my icon theme to HighContrast.

This is what I get:

*****@bluecat:~$ nm-applet

** (nm-applet:2137): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nm-applet:2137): nm-applet-WARNING **: Failed to register as an agent: (32) An agent with this ID is already registered for this user.

Update: 9:07 PM your time.

MoroS, I'm back! 

I had to change my icon theme to HighContrast because I couldn't see my volume icon on my black panel bar.

MoroS

#64
Let's look at the panel settings for a moment: right-click the panel and choose "Panel settings". Go to the "Panel Applets" tab and see if you have the "System Tray" applet on the list. Just in case.

I've got Sparky LXDE running and I'm getting the same messages when running nm-applet, but the icon appears in the upper-right corner (near the clock).
There's no such thing as "impossible". :)

perknh

#65
MoroS, consider the problem [SOLVED]!

Wow --- you did it.  I am now connected to the this forum without using my Ethernet cable!

No, I did NOT have the system tray applet on the list.  I removed it, when I first installed, and replaced it with the LXDE applet -- because I thought LXDE applet was more visually appealing, and because I thought it would do the same thing.  Then I forgot all about the original system tray applet.  :-[

MoroS, you are indeed a problem solver extraordinaire! ;)

Mil gracias, or a thousand thanks.  I'm elated!  ;D

perknh







MoroS

Glad I could help. :) My brain took a beating in the process (I was on the verge of giving up here ;D), I learned a couple of new things about Linux's wi-fi connectivity and made some new assumptions for the upcoming bug reporting tool, so I guess it's a win-win situation. :D

You should keep the system tray though. Not only NetworkManager, but other applications such as instant messengers (like Pidgin, Skype), Sparky-based utils (like APTus) and such leave their icons in the system tray for fast access. The issue with the LXDE's network applet is another case that I'll have to investigate in the future. ;)

For the time beign we hope you'll enjoy Sparky as much as we enjoy preparing it. :)
There's no such thing as "impossible". :)

perknh

#67
You know, MoroS, once I realized how much you knew about Linux, and your ability to patiently persist and work out a problem, I knew if I followed your steps, we get there eventually.

This made me want to work on two sets of skills -- Linux and problem solving.

What sources you were using for Linux, I do not know, but if you have a source on the net where I could read more about Debian and its commands, I like to see it.

The second set of skills you demonstrated is a requirement in life -- problem solving.  And, by your words under your username, you've taken it upon yourself to take a positive approach to problem solving.  This impresses me a lot, and is the best approach I've seen yet.

Thanks to you I learned as much about problem solving here as I did about Linux.

MoroS, I removed LXDE's NetworkManager -- it's useless to me.

Now our next challenge is: how to report this issue to LXDE!

What is the specific issue to report?  Is it that LXDE's NetworkManager doesn't work?  And to whom do we report this issue?  You worked too hard to not have this issue reported.

And don't you worry, I'm keeping that System Tray there -- in my panel!

Thank you, MoroS.  This was a learning experience for me.

perknh



MoroS

Quote from: perknh on August 22, 2014, 12:02:58 PM
What sources you were using for Linux, I do not know, but if you have a source on the net where I could read more about Debian and its commands, I like to see it.
I've been using Linux for about 18 year now, so I don't remember most of the sources. One thing I can say: be curious. Googling for things is the first step. When you find something that seems related to your issue try to find and read some documentation about it. It takes a while, but you build your knowledge from ground up. Reading some things about Linux basics (how it's build in general - not the technical bits, that comes later eventually, what processes are beign run when the system's working) also helps. It can sometimes be a pain, because one won't understand everything at the beginning, but as you gain information, more and more things become clear. As for Debian, well the main page and the Debian Wiki page is a good place to start. :)
Remember that it takes some time to know it all, so don't get discouraged too quickly. ;)

Quote from: perknh on August 22, 2014, 12:02:58 PM
The second set of skills you demonstrated is a requirement in life -- problem solving.  And, by your words under your username, you've taken it upon yourself to take a positive approach to problem solving.  This impresses me a lot, and is the best approach I've seen yet.
Thank you. :) I'm just stubborn, that's all. ;)

Quote from: perknh on August 22, 2014, 12:02:58 PM
Thanks to you I learned as much about problem solving here as I did about Linux.
Don't mention it. It's what we do here. :)

Quote from: perknh on August 22, 2014, 12:02:58 PM
Now our next challenge is: how to report this issue to LXDE!
What is the specific issue to report?  Is it that LXDE's NetworkManager doesn't work?  And to whom do we report this issue?  You worked too hard to not have this issue reported.
Well, the LXDE bugtracker at SourceForge would be a good place to start. The bug would be: "LXPanel network management applet doesn't show wifi networks, but nm-applet does" or something similar. It seems no one reported anything like this yet. I'll install LXDE on my development environment and see if I've got the same problem.
There's no such thing as "impossible". :)

perknh

Thank you,MoroS.

Now I'm curious if you'll encounter the same problem that I had with the LXDE NetworkManager.  Chances are you're not working with a Toshiba C-70 laptop.  If this happens on your computer too, we can be pretty certain the problem is with the applet.

In the meantime, I hope you enjoy your LXDE experience.  The fans of LXDE consider LXDE to be light, fast, and very user-friendly.

perknh


pavroo

I don't think there is anything to report.
The LXDE "Manage Networks" applet doesn't have any option to configure connection.
The second one "Network Status Monitor" can't manage connection too.
So in my way and as you said it's just a mistake and it's nothing to report.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

perknh

Wow!  What an difficult exercise due to one simple error.

I'm really sorry for putting you and MoroS through all of that.  :-[

That was a hard way to learn a lesson.

Please accept my apologies.

Thank you,

perknh

pavroo

There is nothing to apologies.
I only said that there is no reason to report it to the LXDE or Debian team, nothing else.
We all make mistakes because we are only humans and the forum is exactly for situations like that.
I am glad that you have post your case here, because any case like yours make ours knowledge bigger the it was before.
That's the point :)
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

perknh


View the most recent posts on the forum