Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Update broke Virtual Box VBox drivers [SOLVED]

Started by ElQuia, July 21, 2014, 06:33:18 PM

Previous topic - Next topic

ElQuia

Hi running Sparky RazorQT i486 in VirtualBox 4.3.12 on a Windows 7 x64 host

Yesterday I did a full upgrade of sparky. Kernel changes usually break VBox Additions and require re install. Normally not a problem but now I am getting this error:

"unsupported pre-release version of X.Org Server installed.  Not installing the X.Org drivers."

Please ¿How can I go back to previous X.Org Server?

pavroo

I don't think you can do it.
The best way is to reinstall sparky and make a backup of the virtualbox image before making updates.
Anyway Debian devs changing something now with xorg packages so it's better to wait a while with full upgrading the system.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

Quote from: pavroo on July 21, 2014, 08:16:46 PM
I don't think you can do it.
The best way is to reinstall sparky and make a backup of the virtualbox image before making updates.

:( suspected that. Should have taken a snapshot in VBox before update, but I never had this sort of trouble with debian distros & VBox  before ....

QuoteAnyway Debian devs changing something now with xorg packages so it's better to wait a while with full upgrading the system.

I´ll wait some days and do another full upgrade, if not I'll reinstall. I have just discovered sparky, looking arround for a distro for low resources PC's so I had installed and was toying arround with some configs and so before trying it on metal....

OK, thanks, and ANY ideas will be heartedly welcome  ;)

ElQuia

Was thinking  :o

HOW do I reinstall and update WITHOUT getting on system the "... unsupported pre-release version of X.Org Server..."  installed???

pavroo

It's only the one way:
apt-get update && apt-get upgrade
Just avoid dist-upgrade for a few days.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

Quote from: pavroo on July 22, 2014, 01:23:45 AM
It's only the one way:
apt-get update && apt-get upgrade
Just avoid dist-upgrade for a few days.

OK and how many days are a "few days"?  ;D noob question but just to know

pavroo

Don't really know.
I will upgrade all sparky installation this week (I didn't do that last two weeks) and I will have a look what's going on.
I am a little busy with a new application but I should finish it tomorrow or day after.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

OK Thanks.... Pitty to have a 1024x768 window on a HD screen..... all the rest of vbox additions work, its video drivers that wont install due to new x.org

Thanks anyway :)

ElQuia

Ok today did another dist upgrade, new xorg server btw. different error but same results: max 1024x768, vbox driver will not install parts of it:

Installing the Window System drivers
Warning: unknown version of the X Window System installed. Not installing X Window System drivers.

???

ElQuia

SOLVED. Seems a lot of VBox / Debian users had the same problem. On VBox forums found a testing ser of drivers (additions):
https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.3.15-95180.iso
That test version of the GA's got my xorg back as well with the xorg that came out of testing on 23 July, 2014.

View the most recent posts on the forum