Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Shutdown Menu Wont After Upgrade

Started by frogprince, April 30, 2014, 06:50:47 PM

Previous topic - Next topic

frogprince

A new one: I upgraded again this morning, and now when I try to shut down the machine with the panel logout applet, I get an error message:



GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1



So..given my record here, does the Sparky team need any code testers?.. :P

pavroo

#1
Have you followed this instruction already?

http://sparkylinux.org/lxde-systemd/
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

frogprince

#2
Did that, and in the process another apt-get update && apt-get dist-upgrade.   Rebooting after that upgrade left me with no icons or background on the desktop, and a group of error messages about failed dependencies for sparky initialization routines. I did a dist-upgrade -f and an additional forced update to intramfs, and now finally everything seems to work. One must pay careful attention to the error messages during the updates.

creole_cat

Hello Everyone,

I installed Sparky Open Box last night and did the updates and upgrades.
Having the same issue in the menu, the "Restart" and "Exit" functions are not working.

frogprince, could you elaborate on the commands you used to fix this issue.

Thanks,

pavroo

#4
Hi
The "Restart" option restarts Openbox window manager only, but NOT the system.
To get some more info about the "Exit" option run in a terminal emulator:
wm-logout
and show me the output, please.
Tell me what is your Sparky Openbox version: i486 or x86_64 ?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

creole_cat

pavroo,

I am using the i486 version. Here is the output from the wm-logout command:

david@sparky:~$ wm-logout
Traceback (most recent call last):
  File "/usr/bin/wm-logout", line 173, in <module>
    wmlogout = WMLogout()
  File "/usr/bin/wm-logout", line 42, in __init__
    self.gtk_init()
  File "/usr/bin/wm-logout", line 143, in gtk_init
    self.btn_suspend.set_sensitive(self.upower.SuspendAllowed())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "SuspendAllowed" with signature "" on interface "org.freedesktop.UPower" doesn't exist

pavroo

Do you have installed package 'wm-logout'.
Show me the output:
sudo dpkg-query -l | grep wm-logout
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

creole_cat

pavroo,

I guess based on the output, I do not have this package installed:

david@sparky:~$ sudo dpkg-query -l | grep wm-logout
[sudo] password for david:
david@sparky:~$

pavroo

#8
It looks like, you have the old logout script which does not work well.
Simply install the new one:
sudo apt-get update
sudo apt-get install wm-logout
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

creole_cat

pavroo,

That corrected the issue. Thanks very much!!!

View the most recent posts on the forum