Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

How Do I Change wbar in Latest Sparky?

Started by frogprince, April 23, 2014, 05:32:24 AM

Previous topic - Next topic

frogprince

I installed the latest Sparky LXDE.



1.) How can I enable auto-hide for the wbar dock?



2.) How can I change the theme of the icons in the dock? I changed all the rest, but those on the dock didn't change.



Thanks!

pavroo

#1
The Wbar does not have the the auto-hide option. It always works under an opened window so you don't need to hide it.

To change the icon theme go to Wbar-config-> mark selected app-> click "Edit" (Icons tab, middle icon) - it will open the app's edit window. You can't change the icon theme globally, just one icon after one. Anyway you can edit the wbar configuration file if you'd like:

Code:

/home/you/.wbar


Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

frogprince

#2
Pavroo: Thanks, but:



1.) My own strong personal preference is for auto-hide, and the reason is not to hide the dock but to find it quickly. The screen on this laptop is only 26.5 cm by 16 cm, and with auto-hide I could quickly find the dock even when the screen was crowded with several (or a full browser) windows, and not take up precious screen real estate.



2.) I used Wbar-config to try to change the icons on the dock, but none of the Hicolor ones, for example, would show up on the dock even though the software accepted them, and even though they are scalable *.svg files. As soon as I click on "reload", the icon disappears from the dock.



If you have no other suggestion, I'll pursue the auto-hide issue with the LXDE forum. But do you have any suggestions for the icon issue?



Thanks for all your time and excellent support.

pavroo

#3
1. It is not a bug so don't report it on LXDE forum. You can make a suggestion on Wbar project page about that. The fact is, Wbar does not have an auto-hide option at all. If you need it, just contact with Wbar developers: code.google.com/p/wbar/



2. Don't use svg icons. Try for example /usr/share/icons/hicolor/48x48/apps/any-icon.png

Then Accept and Reload.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

frogprince

#4
Pavroo: Thanks, changing the icon file type fixed the problem. I downloaded many more icons from synaptic and will pick through them. I had assumed that an *.svg file would be required for the animation.



Don't worry; I had no intention of filing a bug report with Sparky. Your team are fine integrators, but not usually creators of applications. I did check the wbar web site, and a bug reporting this issue had already been filed. So I voted for it and added a quick comment there. If that gets resolved, I'll be really happy..~(8^})=...

pavroo

#5
If you'd like to try other icon set which can't be installed via Synaptic (it's not in repos), you can download it from gnome-look.org for example. Then unzip the set and move it (as root) to directory:

Code:

/usr/share/icons/




The point of Wbar bug reporting in LXDE forum is the Wbar is NOT a part of LXDE.

So they can't fix it, only Wbar devs can do that.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum