Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

upgrading and sudo problem

Started by breezy, April 17, 2014, 09:42:24 PM

Previous topic - Next topic


Hello, chomping at the learning curve here. First of all i tried to sudo apt-get update and got 'brian is not in sudoers file' so i assume this should be an editing thing but i don't have a clue what to do to fix it.I can su with my root pswd but would still like to fix sudo.Next i tried update after su'ing but got the following:

root@sparky:/home/brian# apt-get update

Anwybyddu stable InRelease

Presennol squeeze InRelease

Cyrchu:1 testing InRelease [166 kB]

Presennol testing InRelease

Presennol stable Release.gpg

Presennol testing/updates InRelease

Cyrchu:2 sparky InRelease

Presennol stable Release

Presennol squeeze/main i386 Packages

52% [2 InRelease gpgv 1,028 B] [1 InRelease 85.1 kB/166 kB 51%] [Yn aros am benSplitting up /var/lib/apt/lists/partial/repo.sparkylinux.org_dists_sparky_InReleaAnwybyddu sparky InRelease

E: GPG error: sparky InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)


I also tried through the menu '-settings-software and update' but nothing happened, no window or notification.

The last problem relating to this is if you notice the terminal output most is in english but what language is "Yn aros am ben?"

This gaelic looking text also pops up in orage which has 17 Ebrill instead of April and in some of the settings there some non english language.

Hoping for a solution, thank you for your time Brian.

PS just noticed the 'network need authentication' line. The network has a good connection and works fine.


Hi breezy.

To fix repository you have to change it:" class="bbcode_url">

Looks like you are using older version of Sparky than 3.3.

Sudo is enabled as default from Sparky 3.3 and above.

If you'd like to use sudo in older version of Sparky, do (as root):


adduser <your-nick> sudo

Create a file in your home directory called:



Place the text inside the file:



Then log out and login back.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks for the quick reply worked a treat. Now i only have an issue with the language which i now know to be welsh. When updating i noticed a reference to 'non-free translation cy-GB' or something like that and the update ended with the welsh for finished/updated not english. Any suggestion how i get uk english as default. I think when i installed it i seen the GB part of the keymap part and selected it away from the default US and probably never thought about the cy bit which i assume is the welsh part. It's not a major issue yet but once i know how to change the default to GB english i hopefully wont have to ask in the future if i get a 'senior moment' and install the wrong language again on another computer. Thanks again for your help. Brian


Menu -> System-> Language will help?
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks again, what a brilliant system, don't know why it's so hard for windows users to understand the benefits of open source.It allows the poorer community access to information and technology that was much harder to obtain in the days of the microsoft monopoly.Long may the free philosophy reign.

View the most recent posts on the forum