Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

<SOLVED>GParted wont start and a. It about keyboards

Started by Linux_Newbi, March 03, 2014, 09:00:02 PM

Previous topic - Next topic

Linux_Newbi

Hi, me again,

I've just reinstalled sparky, and set all my old stuff up(menu is working fine now) but now GParted refuses to start, from the application menu, start menu, and from file browser, I click on it and nothing happens. As far as I can tell everything else works fine. I've tried apt-get update and upgrade but still no luck, I'm thinking of reinstalling it, but when I go to delete it it wants to delete a sparky-openbox-manager as well(or similar, it was a little while ago) which sound pretty important to me, is it safe to delete this? Or should I try something else first?

pavroo

#1
Try to run it in a terminal emulator with the command:

Code:

su
gparted


If it will start up, edit as root the file:

Code:

su
leafpad /usr/share/applications/gparted.desktop


Change the line from:

Code:

Exec=gparted-pkexec


to:

Code:

Exec=remsu gparted


Save the file, log out and log in back.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#2
Ok, thanks, I've tried without root and get command not found, usually it's permission denied or similar if I need root, if this is normall I'll try your way tomorrow! long hall to USA tonight.

Linux_Newbi

#3
ok, done, i get this warning when it starts though:



(gpartedbin:3232): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

======================

libparted : 2.3

======================



(gpartedbin:3232): Gtk-WARNING **: Theme directory scalable/stock of theme NoirCrystal has no size field



root@gilpc:/home/max# leafpad /usr/share/applications/gparted.desktop



(leafpad:3291): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",



(leafpad:3291): Gtk-WARNING **: Theme directory scalable/stock of theme NoirCrystal has no size field





a bit off topic, where can i find out which keybord i have? its an italian notepad.

pavroo

#4
Don't worry about that.



You'd like to find your keyboard model/number or layout?

To check its layout, type:

Code:

cat /etc/default/keyboard


Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#5
I need the layout of the actual keyboard, because it sure isn't what the computer thinks it is. It's Italian I think, includes various letters with accents and the punctuation is all in the wrong place.

pavroo

#6
To change the layout keyboard run SparkyCenter-> System-> Keyboard Layout Settings and set yours up.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#7
Yes, but I don't know what mine is!

pavroo

#8
What is your machine name, model, number, etc.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#9
HP 2133, Italian or French origin I think, it sure isn't an English keyboard

pavroo

#10
It looks like normal keyboard so try to configure with "standard pc-105-keys Intl" and your language after.

If does it not work, try HP keyboards, there is a few options, but pc-105 should be fine I hope.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#11
Ok, thank you ever so much, there are just so many options and I had no idea what half of them mean.

View the most recent posts on the forum