Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

<SOLVED>Broadcom wifi not working on HP2133 netbook

Started by Linux_Newbi, February 20, 2014, 06:21:45 PM

Previous topic - Next topic

Linux_Newbi

I havedoone a full install on an old 2133 notebook i have lying around, works fine exept i cant get the wifi to work, it dosent appear n the network menu, and i cant find any info on the driver online, can anyone help? please note i'm verry new to linx.

pavroo

#1
Show me results of two commands from a terminal: 'lspci' and 'lsusb'.

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#2








sorry they are images, cant get online on hp yet, ethernet cable MIA

pavroo

#3
It's OK.

But you can use Lxterminal or MATE-terminal, depence what desktop you have (what desktop/sparky version you have?)

Don't run the system in text mode, run it as normal mode and run from menu-> accesories-> terminal, log in as root:

Code:

su
modprobe -r b43


If it does not show any problems, run:

Code:

modprobe b43


Then check your wifi networks.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#4
Thanks, I'm using ultra, stupid question, I'm a ubento user, how do you log in as root in the terminal?

I am running gui, just full screen xterm to make text fit, didn't know ther was a text only mode.


pavroo

#5
If you have Ultra, you should running Openbox desktop.

If so, right click of your mouse-> choose "Terminal emulator".

Then type:

Code:

su


and type root/admin password you created during system installation on a hard drive.

Then type:

Code:

modprobe -r b43
modprobe b43


and check network icon on the panel - networks names should be displayed there.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#6
Thanks

Linux_Newbi

#7
Ok, this works great, but isn't permanent, is there any way to get it to run automatically on startup, sort of .bat in startup equivalent?

pavroo

#8
Login as root/admin in a terminal emulator as before and edit 'modules' file, just copy the text and past it to the terminal:

Code:

leafpad /etc/modules


Add the text below to the file just before 'loop', so it has to looks like that:

Code:

b43
loop


Then save the file, close everything and reboot your machine.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#9
Thank you, is ther a webpage anywhere explaining what the problem was? I'd like to know so if something similar happens again I can fix it.

pavroo

#10
No, it is not.

It happens if a module of a device (a driver) is not loaded automatically.

That's why the forum exist for.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#11
Yes, but I feel bad bugging you all the time, and I want to learn.

pavroo

#12
Don't be :)

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

kevjonesin

#13
I just started playing with Sparkylinux 3.4 E18 (live usb) and noticed that a number of Broadcom drivers are 'blacklisted' by default in:



/etc/modprobe.d/broadcom-sta-common.conf



Which probably relates to Linux_Newb-i having had to manually enable the 'b43' driver.





As for myself, I just adapted the command ("modprobe -r b44 ...") to enable the 'b44' kernel module/driver to access my "Broadcom Corporation BCM4401 100Base-T (rev 01)" Ethernet controller. My wired connection is working now, but I thought I'd share the detail I learned while sorting it out.


configX

What's interesting is that I had this same issue on an older Intel iMac with the LXDE edition but it worked out of the box with the JWM edition.

View the most recent posts on the forum