Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

application menu problem

Started by Linux_Newbi, February 26, 2014, 06:09:04 PM

Previous topic - Next topic

Linux_Newbi

When i try to acess the applications section of the rightclick menu on the descop(obmenu), i tells me that there is an invalid output from pipe-menu '/usr/lib/marchobmenu/mom-deamon.py show'. this only effects one user (the one created at instalation). I am running ultra with LXDE desktop.



thanks.

pavroo

#1
Are you running Ultra Openbox or have you installed LXDE to the Openbox desktop?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#2
I have installed LXDE, but the problem still effects the main user in openbox, whereas the other user is fine in both LXDE and openbox

pavroo

#3
The marchobmenu does not start on any different desktop then Openbox automatically.

That why it doesn't work.

If you log out from LXDE and log into Openbox desktop it should works.

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#4
It doesn't work on openbox either, same error, and the rest of the menu works just fine, directories, wether, config etc... I set it to auto start in LXDE(not in the obmenu config, a tick box in the desktop session manage, I think) and it works fine with other users, in both openbox and LXDE

pavroo

#5
Open Synaptic, find package 'python-xdg' and tell me what is the version of it, please.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#6
Will do, but not before tomorrow, plane leaves in 30 min

Linux_Newbi

#7
ok, version 0.19-5, the latest version apparently.

pavroo

#8
It's fine.

The problem is with the marchobmenu dependencies I think.

The marchobmenu is deprecated and it works on older libs of Debian stable "Wheezy".

That's why there is older 'python-xdg- 0.19.5' package but the newest one is 0.25.

Probably some upgrades made changes and the menu is not compatible with the newest libs now, I'm not really sure.

I suggest to stop using marchobmenu at all, change it for standard Debian's menu, there is a guid how to do it:

http://sparkylinux.org/marchobmenu-bug/

Anyway I don't want to keep developing Ultra Edition anymore, but I will do something else instead of it.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Linux_Newbi

#9
so should i change distros then?

pavroo

#10
If you have LXDE installed over Ultra Edition, you don't have to.

LXDE is stable and very fast.

Just don't use marchobmenu.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum