Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Applications Gone After Last Update

Started by frogprince, October 17, 2013, 05:26:45 PM

Previous topic - Next topic


Hi, I'm running Sparky on an old Dell X1 laptop. Seems to be a good match, but after my last update, I lost the wireless connection application.

The icon is gone from the panel, and clicking on that entry in the menu does not open the window.

I tried a wired connection, and that works. So as root, I tried to open Synaptic. I got an error:

root@dellx1:/home/myusername# synaptic

(synaptic:3277): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(synaptic:3277): GLib-GObject-WARNING **: /build/glib2.0-Ot8bbC/glib2.0-2.36.4/./gobject/gtype.c:4239: type id `0' is invalid

(synaptic:3277): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

Segmentation fault

So I ran apt-get update and apt-get upgrade. Some new packages were installed, but still no wireless.

My next thought was to try aptitude reinstall. So I looked at the properties of the menu entry, and found the command nm-connection-editor.

So I tried:

root@dellx1:/home/myusername# aptitude reinstall nm-connection-editor

Couldn't find any package whose name or description matched "nm-connection-editor"

Couldn't find any package whose name or description matched "nm-connection-editor"

The following packages will be REMOVED:

g++-4.7{u} libamd2.2.0{u} libboost-date-time1.53.0{u}

libboost-filesystem1.49.0{u} libboost-regex1.49.0{u}

libboost-system1.49.0{u} libboost-system1.53.0{u} libdvbpsi7{u}

libebml3{u} libgcr-3-1{u} liblavfile-2.0-0{u} liblavjpeg-2.0-0{u}

liblavplay-2.0-0{u} libmatroska5{u} libmjpegutils-2.0-0{u}

libmpeg2encpp-2.0-0{u} libmplex2-2.0-0{u} libopenraw1{u}

liborcus-0.4-0{u} libstdc++6-4.7-dev{u} libtracker-sparql-0.14-0{u}

libumfpack5.4.0{u} libwebp2{u} libx264-123{u} libx264-135{u} libzip2{u}

python-aptdaemon{u} python-aptdaemon.gtk3widgets{u} python-defer{u}

python-gnupginterface{u} python-pkg-resources{u}

python-software-properties{u} wwwconfig-common{u} xulrunner-10.0{u}

0 packages upgraded, 0 newly installed, 34 to remove and 1 not upgraded.

Need to get 0 B of archives. After unpacking 59.8 MB will be freed.

Do you want to continue? [Y/n/?] n


root@dellx1:/home/mikeandanita# apt-get reinstall install nm-connection-editor

E: Invalid operation reinstall

root@dellx1:/home/mikeandanita# apt-get install nm-connection-editor

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package nm-connection-editor

What package name should I use to reinstall? Is there a better way to rebuild this compromised system, or do I simply have to suck it

up, back it up to a USB drive, and reinstall?

Thanks in advance.


It looks like a root user's GTK problem.

Try to change the system theme with root privileges then log out and log in back.

Check here, it's the same problem:" class="bbcode_url">

Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


pavroo: Thanks for your kind response. I tried the above:




and the dialog box showed up. I tried selecting multiple other themes, clicked on "apply" and "close", but nothing would change. I tried logging out and back in, and rebooting. The system only shows up with the Sparky3 theme, and no wireless application. Do I need to install some of these other themes? Or is there something else wrong?

Thanks again.


You can try any different theme. Try Adwaita as the first, it should works.

Lxappearance has a small bug, read here:" class="bbcode_url">

But check is Sparky3 theme set up for root user, in file:



the line:



Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


pavroo:  As it turns out, the lxappearance bug was the culprit. As noted in the above link, the first two files (/home/you/.gtkrc-2.0 and /home/you/.config/gtk-3.0/setting.ini) were set correctly by lxappearance to Adwaita, but the third file in the link above (/home/you/.config/lxsession/LXDE/desktop.conf) was set to Sparky3. Setting all three file entries to Adwaita, and then logging out and back in restored both Network Connections and Synaptic. Why the Sparky3 theme quit working I have no clue. I only note that the problem appeared after an update.

Thank you, sir! We're back in business without a reinstall, and I'm grateful.

View the most recent posts on the forum