Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

How Can I Implement Tapping?

Started by frogprince, November 04, 2013, 04:46:52 AM

Previous topic - Next topic

frogprince

I'm running Sparky on a Dell X1 laptop. I'd like to be able to tap on the trackpad to "click the mouse", which is what I'm used to. I've opened Sparky Center/Hardware/Pointing Devices, and the track pad is enabled. I can move the mouse fine, and the track pad buttons work fine, but tapping won't work no matter what speed I choose. Am I missing something?



Thanks in advance.

pavroo

#1
Try to run a command:

Code:

synclient TapButton1=1


If will it work fine, add it to the system's autostart.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

frogprince

#2
pavroo:ooh! That works! But how then do I add a command to Sparky Center/System/Custom Startup Services? I can't seem to find a way to enter an additional command.



Thanks!

pavroo

#3
Custom Startup Services-> right mouse click-> Add row

Then type Command: synclient TapButton1=1

Name: TapButton

Discription: TapButton

Then OK.

Restart system to find out is it works fine.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

frogprince

#4
pavroo: thanks for your patient and quick response. When I attempt the above, Custom Startup Services will not accept the "=1" at the end of the command.

I type:



synclient TapButton1=1



and what gets entered is



synclient TapButton1



I broke down and RTFM'd a bit, and opened up /home/myusername/.config/autostart in Leafpad, and found:



[Desktop Entry]

Encoding=UTF-8

Name=TapButton

Comment=TapButton

Exec=synclient TapButton1

StartupNotify=true

Terminal=false



I added "=1" to Exec=synclient TapButton1, saved and rebooted, and everything works properly. But when I open Sparky Center/Custom Autostart, the =1 still does not show in that line in the window. Could there be a number-of-digits mask somewhere that isn't big enough for this command? Or ???



I also inadvertantly added an additional null line in the Custom Autostart window that will not go away with the "delete line" command.



But right now, I'm pretty happy with Sparky on this machine. Thanks for all your hard work!

pavroo

#5

Quote:

I added "=1" to Exec=synclient TapButton1, saved and rebooted, and everything works properly. But when I open Sparky Center/Custom Autostart, the =1 still does not show in that line in the window. Could there be a number-of-digits mask somewhere that isn't big enough for this command? Or ???


I think the Custom Startup Services script does not recognize the  "=1"
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

73

#6
Change the line "terminal=false" to "terminal=true" and then add the "=1" again. That worked for me :)

frogprince

#7
boxcartenant: thanks for your tip, but it didn't work on my X1. Not only would Custom Startup Services still not show the "=1", but I lost all tapping ability. Putting the line "terminal=true" back to "terminal=false" restored the tapping function.



Phase of moon? Wolfbane pollen concentration? Intel drivers? It's working now, so I'll leave it that way, and I'm happy...~(;^})=....



Thanks for your time!

View the most recent posts on the forum